sass&compass开发环境搭建

安装 Ruby(自带gem)

  1. 官网下载安装即可(32/64都有)
  2. 安装时不要忘了勾选添加到环境变量path中
  3. 安装成功

使用gem安装sass和compass

  1. 修改gem软件包安装源为淘宝镜像:
    1. 移除原有sources:gem sources --remove https://rubygems.org/
    2. 添加淘宝的源:gem sources -a https://ruby.taobao.org/
    3. 查看是否替换成功:gem sources -l
  2. 使用gem安装sass和compass:
    1. 安装sass:
      gem install sass
      sass -v

    2. 关于gem的其他常用命令:
    3. 更新所有的gem安装程序:gem update
    4. 安装某一个特定版本的ruby程序:gem install sass --version=3.3
    5. 删除某一个特定版本的ruby程序包:gem uninstall sass --version=3.3
    6. 列出本地已经安装的所有的程序包:gem list

sass简单使用

  1. 通过命令sass test.scss test.css:
    1. test.css
    2. test.css.map(用来映射scss文件和css文件每条规则,方便调试)
    3. test.scss

compass的安装

  1. gem install compass
  2. compass -v
feihu分享到:

          

You may also like...

Scroll Up